Performance degradation
Incident Report for AnyDesk
Resolved
This incident has been resolved.
Posted Feb 07, 2023 - 15:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 07, 2023 - 14:19 UTC
Investigating
We are currently experiencing performance issues in Europe, we are working hard to resolve the problem. We apologize for any inconvenience it may have caused
Posted Feb 07, 2023 - 09:10 UTC
This incident affected: AnyDesk Global Network (Europe).