Service Degradation
Incident Report for AnyDesk
Resolved
This incident has been resolved.
Posted Dec 15, 2022 - 12:35 UTC
Investigating
We are currently experiencing a high volume of traffic that is causing some service degradation at the moment. We are looking into ways to mitigate any service disruptions that you may be experiencing. We apologize for any inconvenience this may cause.
Posted Dec 15, 2022 - 11:24 UTC
This incident affected: AnyDesk Global Network (Americas, Europe).