Major outage - Online shop

Incident Report for AnyDesk

Resolved

This incident has been resolved.
Posted May 13, 2025 - 09:34 UTC

Investigating

We are currently facing major with our Online Shop
Our team is investigating the root cause at this moment.
As soon as we have identified the issue we'll apply a fix, follow this page to receive an update.
We apologize for any inconvenience this may cause.
Posted May 13, 2025 - 09:08 UTC
This incident affected: Online shop.