Performance degradation
Incident Report for AnyDesk
Resolved
This issue has been fixed. We apologize for any inconvenience it may have caused
Posted Mar 02, 2023 - 14:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2023 - 14:02 UTC
Investigating
We are currently experiencing performance issues in Europe and working on a quick solution.
We apologize for any inconvenience it may have caused
Posted Mar 02, 2023 - 13:30 UTC
This incident affected: AnyDesk Global Network (Europe).