A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2025 - 11:17 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 17, 2025 - 11:10 UTC
Investigating
Some our customers from South Korea, Japan and Taiwan are having issues to connect to AnyDesk Global Network. Our team is working on the fix. We apologize for any inconvenience it might have caused.
Posted Jul 17, 2025 - 09:39 UTC
This incident affected: AnyDesk Global Network (Asia).