Performance degradation
Incident Report for AnyDesk
Resolved
This incident has been resolved. We are sorry for any inconvenience it might have caused
Posted Mar 09, 2023 - 15:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2023 - 15:15 UTC
Investigating
We're facing some performance degradation issues. We are sorry for any inconvenience it might have caused.
Posted Mar 09, 2023 - 14:49 UTC
This incident affected: AnyDesk Global Network (Europe).